2010-06-21 Code Review

Call-in Information

Call+1-712-432-0075* or Skype a voice call to freeconferencing
Enter the code*305801

Screen sharing

Attendance

  • Jeremy Keiper

  • Sy Haas

  • Wyclif Luyima

  • Nyoman Ribeka

  • Ben Wolfe

  • Darius Jazayeri

Tickets to review

Ticket 818

  • get Burke to sign off on the fact that ActiveList is a joined subclass within the ActiveListItem.hbm.xml file

    • the hierarchy is done within a single hibernate file

  • table fixes

    • tinyint h1. > smallint

    • uuid> char(38)

    • add foreign keys

    • change allergen to allergy

  • ActiveListItem.java:

    • should extend BaseOpenmrsData

    • switch from using retired to voided

    • create a constructor that takes an Integer

    • create a convenience constructor that takes parameters for all properties

    • should use a not-null constraint for the start_date

    • add a description to stopObs

    • add hashCode method

  • ProblemListItem.java:

    • add convenience constructor

    • add equals and hashCode methods

    • figure out the exact meaning of "ACTIVE, RESOLVED, RULE_OUT" statuses and write javadocs for them

    • rename to Problem.java

  • AllergyListItem.java:

    • add equals method

    • switch allergyType to enum and fix getters/setters

    • rename to Allergy.java

  • ActiveListService.java:

    • add getProblemByUuid()

    • add privileges and privilege checks

      • similar to obs

      • separate for problems and allergies

    • move get/save logic to PatientService

  • DWRActiveListService.java:

    • move methods to DWRPatientService

  • ActiveListServiceTest.java:

    • if PatientService delegates to ActiveListService, then it's fine to leave the tests here

    • move executeDataSet to @Before method

  • UI

    • reorder table and form to match (i.e. put Type first in table)

    • fix allergen vs reaction; allergen = what you are allergic to, reaction = symptom

    • date should not be hidden by default

    • better descriptions for the options on resolving an allergy

    • ask the paradox what "other" means when resolving a problem

Ticket 260

Ticket 2401

  • change name of attribute to javaScriptEscape, similar to spring nomenclature (i.e. urlEscape, htmlEscape)

  • apply the escaping to the entire string buffer instead of just personName

  • fix the description in the TLD file (not wildcard)